SmartVPS - едно хостинг решение за много акаунти! Всеки отделен акаунт е с включени безплатни бекъпи, addon домейни, PHP-FPM с OPcache и кеширане на съдържание за светкавично бързи сайтове. И всичко това на страхотна цена!
50% ОТСТЪПКА ЗА ВСИЧКИ ХОСТИНГ ПЛАНОВЕ, ЗА ДА ПРЕМЕСТИТЕ ЛЕСНО СВОЯ БИЗНЕС ОНЛАЙН

Поддържани версии на PHP

Следните версии на PHP са инсталирани на нашите сървъри:

Поддържани PHP технологии

Следните технологии за изпълнение на PHP скриптове се поддържат на нашите сървъри:

  • CGI
    CGI (Common Gateway Interface) позволява на сървъра да работи с външни за него програми, каквито са PHP скриптовете. В сравнение с FPM CGI е по-бавна технология и използва повече системни ресурси, но е възможно да се налага някои скриптове да се изпълняват чрез CGI от съображения за съвместимост.

  • FPM с OPcache
    FPM (FastCGI Process Manager) ползва FastCGI протокола. FPM поддържа работещи процеси за изпълнение на заявки, за да намали използването на ресурси на сървъра при стартирането на нови CGI процеси. Това води до по-бързо изпълнение на заявките. FPM работи в комбинация с OPcache - система за кеширане, която пази предварително компилиран байт код в сървърната памет. Това допълнително увеличава производителността и подобрява скоростта на зареждане.

Версия и технология на PHP по подразбиране

По подразбиране, всички нови акаунти се конфигурират да ползват най-новата PHP версия, която е налична на сървърите ни, заедно с FPM с OPcache. Всеки акаунт ползва версията и технологията, с които е бил конфигуриран в началото, освен ако не промените тези настройки ръчно. Ако акаунтът Ви е създаден, когато 7.3 е била най-новата версия на PHP и CGI е била технологията по подразбиране за изпълнение на PHP скриптове, той ще остане с тези настройки, докато не ги промените.

Версията и технологията за нови поддомейни се управляват по същия начин - те ще бъдат настроени автоматично с най-новата версия на PHP и с FPM с OPcache.

Промяна на версията/технологията на PHP

Можете да смените версията и технологията за PHP поотделно за всеки поддомейн в акаунта си на страницата PHP настройки в Контролния панел.

Ако искате да промените определени настройки на PHP, има повече информация как да направите това в статията PHP настройки.

Версия на PHP за интерпретатора на командния ред

По подразбиране, PHP на командния ред (php.cli) използва най-новата версия на PHP на сървъра към момента на отваряне на акаунта. В някои редки случаи е възможно акаунт да бъде конфигуриран с по-стара версия за php.cli заради остарели настройки.

Можете да проверите или да промените версията за PHP на командния ред от раздела Избор на PHP CLI версия на страницата PHP настройки в Контролния панел.

Списък с пътеките до изпълнимите файлове за всички версии на PHP, които се поддържат за акаунта Ви, има на страницата Информация за сървъра в Контролния панел. Можете да ползвате тези файлове, за да изпълнявате скриптове с конкретна версия на PHP чрез планирани задачи или чрез командния ред.

Ако искате да изпълните скрипта ~/www/www/directory/file.php с PHP 7.2, например, можете да ползвате следната команда:

/usr/local/bin/php72.cli ~/www/www/directory/file.php

Смяна на PHP версията на PHP само за определена директория

Информацията в този раздел се отнася само за поддомейни, които ползват CGI.

Има повече информация за приоритетите на конфигурационните файлове на PHP в статията Конфигурационни файлове за PHP и техния приоритет.

Важно: Ако искате да смените версията на PHP за целия поддомейн, можете да намерите повече информация за това в раздела Промяна на версията/технологията на PHP на тази статия.

Можете да настроите определени директории да ползват дадена версия на PHP с CGI, като добавите директива в .htaccess файла в директорията (можете да го създадете, ако не съществува). Таблицата по-долу показва директивите, които трябва да ползвате за съответните версии на PHP:

PHP версия .htaccess директива
PHP 7.4 AddHandler application/x-httpd-php74 .php
PHP 7.3 AddHandler application/x-httpd-php73 .php
PHP 7.2 AddHandler application/x-httpd-php72 .php
PHP 7.1 AddHandler application/x-httpd-php71 .php
PHP 5.6 AddHandler application/x-httpd-php56 .php
PHP 5.3 AddHandler application/x-httpd-php53 .php

 

PHP 5.3 и PHP 5.6 са остарели и не се поддържат

PHP 5.3 и PHP 5.6 не се поддържат от разработчиците на PHP и няма обновления за тях. Поради тази причина, тези версии на PHP може да бъдат премахнати от нашите сървъри по всяко време. Ако ползвате някоя от тези версии на PHP, Ви препоръчваме да ги смените с PHP 7. Имайте предвид и че PHP 5.3 и PHP 5.6 на нашите сървърите може да не съдържат всички стандартни разширения за PHP от съображения за съвместимост.

PHP 5.3 може да се ползва само с CGI. Не е възможно да се пусне FPM с OPcache за PHP 5.3 от съображения за сигурност и производителност.